swirling sands

Use Psunami Water to create sand dunes and
a swirling sand pit. A cool alternative use for

a plugin designed to create water simulations.

a tutorial for : psunami water

uilAmi

photoreal 3D water simulation & effects.

[ from Digital Anarchy ]

f/x tools for revolutionaries.




psunami water : swirling sands

For this tutorial, we are changing the name of ‘Psunami Water’ to ‘Arrakis’.

Those of you who are well-read will understand the reference. The rest
of you heathens are required to buy a book called ‘Dune’, read it, and
then return to this tutorial. Such is the price one must pay for not already

having read one of the best sci-fi books ever. But we digress.

Of course, the reason for the name change is that —

we’re about to create a swirling sand pit in the
middle of the desert. In this tutorial, we will turn off
the water simulation, and just use Psunami’s built in
3D displacement mapping and texture controls

This will give you a glimpse into the power of the 3D
displacement controls. You can have up to 3 other
layers affect Psunami, either as a displacement map,
texture, or both.

Not exactly what you would expect from a filter

designed to do photorealistic water simulation, but [ figure 1]
Psunami is capable of doing quite a bit more than

you would think at first glance. So let’s get started.
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01- project setup

From your download folder, open up the psu_sands.aep
project file in After Effects. The ‘Final’ comp shows your
finished piece.

B commposition
B commposition
B compozition

B Folder |

B commposition

1 I Marne

You can also play the QuickTime movie called psu_
sands-final.mov to see the final composition that you
will create. [ figure 3]

[aalolal & lew: 1 1« »
[ figure 3]

02- what is 3D displacement?

In this tutorial, both the sand dunes imagery and
the swirling sand imagery will be created using

3D displacement maps. So you’re going to become
very familiar with this subject.

‘3D displacement’ is basically the same as ‘2D
displacement’. Difference is that you’re pushing
around polygons instead of pixels.

For both kinds of displacement, you set a
displacement amount and then match a grayscale
image to your original image. Where the pixels

(or polygons) meet determines how the original
image will be pushed around, and by what amount
of distance.

2D displacement example: [ figure 4 |

- White pushes the pixels the maximum distance ' .
in the positive direction (up or to the right).

- Black pushes the pixels the maximum distance

Al
in the negative direction (down or to the left). Q,’ [ I

L 0 5
- Shades of gray push the pixels some percentage i o ‘ “{L"'.i
of the maximum amount. Normal Displaced
- The closer to neutral/middle gray the less the
pixels in the original image are affected. [ figure 4 ] The 2D displaced figure, at right,
- Neutral gray causes no displacement at all. follows the shades of gray it is set against. Top,

white pixels push the flag upwards. Bottom,
black pixels push the model’s leg downwards.
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The same principles holds true in 3D displacement:
[ figure 5]

- White pushes the polygons up the maximum amount.
- Black pushes the polygons down the maximum amount.

- Shades of gray push the polygons some percentage of
the maximum.

Now let’s continue on to create your own grayscale
displacement map. We’ll abbreviate that term as ‘dismap’

from Now on. [ figure 5] 3D displacement example

03- begin the dune dismap

First step is to create the grayscale image that will create
the dunes. We've already created it, and that is the ‘Dune
Dismap’ comp. Check that comp out, then close it so you
can make your own.

To start your own, create a comp that is 1024x768. This
is a pretty large comp in order to give us a little extra
resolution, since we’re going to use it as a displacement
map [dismap].

Now create a new Solid layer that’s the same size as the _
comp (1024x768). [ figure 6]

04- add noise and blur

Apply Fractal Noise (Effects>Noise>Fractal Noise) to the

Solid. The default settings of the Noise filter work fine,

so there’s no need to make any changes.

However, we do want to blur the noise a bit. We can Bi

accomplish this by applying a Gaussian Blur (Effects>

Blgr & Sharpen> Gaussian Blur). Set ‘Blurriness’ to 25. [ figure 7a] [ figure 7b ]
[ figure 6]

This will smooth the noise out and give us smoother
sand dunes. [ figure 7a ] If left as is, the extra detail in
the noise would create a very rough surface. [ figure 7b ]
This might work if we wanted a rocky terrain, but for sand
dunes, it helps to smooth things out a bit.
Smooth
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05- create a gray solid

We’re going to tile this displacement map; that is, repeat
it in a checkboard grid. We don’t want the tile seams to
show where sand dunes might abruptly stop or start, as
that would kill the believability.

To remedy this ‘edge creep’, we can put a new Solid
layer behind it. The layer should be dark gray. This puts
a neutral color around the dismap’s edges and creates a
nice even seam. [ figure 8 |

This might look a bit weird if the camera was going to
move around. A different solution would be to shrink the
comp. But the camera is going to be stationary, so we can
get away with this fix.

06- create a circular mask

Now we’re going to create the area that the sandpit is
going to be in.

Create a new Solid layer that’s 400x400 and a neutral
gray color (value of 128 in each RGB channel). [ figure 9]
Those dimensions should plop our new Solid in the middle
of the screen. That’s a fabulous location, so we’ll leave it
there.

Now create a perfectly round mask that’s about the size
of the Solid. Grab the Circular Mask Tool, click and drag
from the upper left corner to the lower right corner while
holding the Shift key. Nice round circle, nice round mask.
[ figure 10]

07- begin the swirling dismap

Now we want to create the dismap for the swirling sand.
This will fit into the circular area we created in the first
dismap. So, it needs to be the same size as that area.

Open the ‘Whirlpool’ comp to look at what we’ve already
done. Then close that comp and create a new comp that’s
400x400.

Idune dismap - k@ﬂ i &

1'9.1 2 llfyer Marne

O 1 [ fractal noise
O 2 M ISelid1]

[ figure 8]
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[ figure 9]

[ figure 10 ]
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Create a new Solid that’s also 400x400. Again, apply a
circular mask that’s about the size of the layer using the
Shift-drag method from before.

To create the whirlpool, we’re going use Fractal Noise and
the Twirl filter to create a spinning, swirling effect.

08- apply noise and blur

The trick to our whirlpool dismap is that we only want the
sand to move down. Remember from STEP 02 that any
shade lighter than neutral gray will cause the polygons to
be displaced upwards. Our effect won’t look very whirlpool-
like if the sand flew up in the air.

= f Levels Reset About
Monkeys can fly but sand doesn’t, and if you want Effect Favorites [ Tane
monkeys to fly that’s your own neurotic hangup to el RGE ¥
deal with outside of this tutorial. WE need to make Ll Titstanram

sure our shades of gray are all darker than neutral
gray. This will cause all the polygons to be displaced
downward.

Apply Fractal Noise to the solid. Leave it at the default

settings. Apply Gaussian Blur and set its blur to 10. ?

[¢ Input Black 0.0
09- apply levels B Input White 255.0

[+ Garnrma 1480
Now apply the Levels filter (Effects> Adjust> Levels). I Output Black £1.0
This is where we’ll make sure all our shades of gray b Output White 1220

are darker than neutral gray. [ figure 11 ]
[ figure 11]

Set the ‘Output Black’ to 61, and set ‘Output White’ to

122. This will limit the shades of gray. [ figure 12 ]

If you don’t understand how this process works, we
highly recommend you read up on the Levels filter.
Probably won’t be as fun to read as the Dune novel,
but it’s an extremely important filter to understand.

[ figure 12 ]
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10- apply twirl v Reset About...
Next, apply the Twirl filter and set ‘Angle’ Effees Earmnies [_Mane

to 125. = i Angle Q% +3375°

We need to animate the Twirl, so go to 01:14 @

in the Timeline and set a keyframe. Jump to B & Twirl Radius 0.0

06:14 in the Timeline and change the value to ¢ | Twirl Certer -] =000, 2000

1x 125. This makes one revolution plus 125

degrees. [ figure 13 ] [ figure 13 ]

This setup will give us a nice twirling
animation. [ figure 14 ]

11- apply ramp

To make this effecct really work, we want the
sand around the edges not quite as affected
as the sand in the middle. And we want the
sand in the center to fall inward first, then

slowly drag the sand around the edges in. [figure 14 ]
To accomplish this, we will need the shades = |f Ramp Reset b
of gray located around the edge of the twirling | Effect Favorites e
fractal noise to be closer to neutral gray. I B Shae 6t Ramn ] 2000, 2000
|
As with the Dune Dismap, create a new Solid [EEE R ey alor |:|
that is neutral gray (128 per RGB channel) |+ ©/End of Ramp 2] 200.0, 4000
and put it behind the whirlpool layer. This * ) End Color (=]
will prevent any displacement from occuring : &/ Ramp Shape |__Radial Ramp |
around the edges of the map. [+ & Ramp Scatter 0.0
| [2 & Blend With Original 0.0 %

Create another new Solid and apply the Ramp |
filter (Effects> Render> Ramp). Set the ‘Ramp [ f 15 ]
Shape’ to Radial Ramp. Set the ‘Start Color’ gure
to white. Set the ‘End Color’ to black. Set the
‘Start of Ramp’ to 200,200. | figure 15 ] I dizmap ‘vhirlpnul -ll\:lune texture ‘Main
In your Timeline, show the Transfer Modes 0;00;03;,00 (29.97 fps) E
section. Change the track matte for the | [%] # || Laver name | r0de T TrkMat |
whirlpool layer to ‘Luma Matte’ and use the O 1 L[ ramp Hormal = |
Ramp layer. [ figure 16 ] O 2 [l[#] noise [Hormal+] [Luma -]

IO % [F[Selid1] [Mormalw|| | HNone |
The result: a seamless neutral gray animation.
[ figure 17, next page ]

[ figure 16 ]
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12- apply Psunami

In this final stage, we’ll put both displacement
maps into a new comp, and create Arrakis!

Create a new 640x480 comp and name it ‘Arrakis’.
Put both your ‘Dune’ dismap and the ‘Whirlpool’
dismap into the Arrakis comp. Turn both of them
off in the Timeline (click the eye icon off).

Create a new Solid that’s 640x480, make a comp-
size Solid layer, and apply Psunami - er, Arrakis [ figure 17, previous page ]
- from the Effects> Digital Anarchy menu.

13- change settings

In the ‘Render Options’ section, change the
‘Render Mode’ to Wireframe. Psunami can be a bit
slow so when you’re setting things up, so it’s best
to work in Wireframe mode. This mode renders
quickly and makes setup a snap.

The first thing we need to do is go down to the
‘Primary Waves’ section and turn off the water
simulation. We do this by setting the ‘Wind Speed’
parameter to 0. Once you do this, you’ll notice the
3D grid now becomes flat. [ figure 18 ]

[ figure 18]
Now go to the ‘Light 1’ section, and set ‘Light
Elevation’ to 75, and set ‘Glitter Scale’ to 0.
== Image Map 1
. Map Layer: | 4. dune disrap ¥
14- image map 1 Map is: [__Displacernent
Open up the ‘Image Map 1’ section of Psunmi. Displace on:
We will create our dunes with this map. For ‘Map [+ & Dizplace Intensity 10.00
Layer’ choose the ‘Dune’ dismap comp that you [+ & Center ¥ (M} 50,00
placed a moment ago. [ figure 19 | [ & Center v (M) .00
. . : . b & Angle Dx+300°
You will notice the 3D grid becomes kind of e .20
‘lumpy’ once we do this. Nothing moves, as you —
should expect. b & Scale ¥ Bzt
[ &| Blur drmount 2,00
Layout: [ Tile
[ figure 19]
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Set ‘Displace On’ to green. For this project it could

actually be red, green, or blue. Since we’re dealing = Image Map 2
with a grayscale image, all the channels look the Map Layer: [ 3 whirlpeol =
same. Map is: Displacernant
Set “Displ . 1 d ch ] , Dizplace on:
et Displace Intensity’ to 10 and change ‘Layout b [& Displace Intensity ——
tO Tlle. .............
[+ &) Center ¥ (M) 0,00
[+ & Center Y (M) 0.00
15- image map 2 b S| Angle O 4300 °
[ & Scale ¥ 0.20
Now open up the Image Map 2 section. [ figure 20 | b &) Scale ¥ 020
We’ll use this to create the whirlpool of sand, so | Blur 4 - oy
hoose the ‘Whirlpool’ comp layer for ‘Map Layer’ b Bl Bl dmaun o
¢ ’ Layaut: |__Mormal
We want ‘Displace On’ to be Green, ‘Displace [ figure 20 |

Intensity’ at 27.25, and ‘Layout’ at Normal.

By default the images line up on top of each other. _

Since we created the gray circle in the middle of
our Dune dismap, the Whirlpool dismap is centered
on top of it, falling right into the gray circle.

12- camera and render

Let’s back our camera up a little bit so the gray
circle of the Dune dismap is directly in view. Open
the ‘Camera’ section and set the ‘X east-west’
parameter to -20.

Go back to ‘Render Options’ and change the [ figure 21]

‘Render Mode’ to Realistic. After a few moments,
you will have a render that looks pretty good.
[ figure 21]

The sand needs a texture, so we’ll do a quick and
dirty one. Hey, it’s sand... it should be dirty.
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13- sanding the dunes

Still in our Arrakis/Psunami comp, create a new Solid (last

== | F HuefSaturation

one, promise!) that’s 640x480. Apply Fractal Noise to it.

Set ‘Contrast’ to 50, and ‘Scale ‘to 5.

Apply the Hue/Saturation filter (Effect> Adjust> Hue/

[+ & Colorize Hue

Saturation). Turn on ‘Colorize’. Thn change ‘Colorize Hue’ b &) Colorize Satur ation

to 45 and ‘Colorize Saturation’ to 20. [ figure 22 ]

[ &| Colorize Lichtness

We now have a dirty beige texture. Precomp this (Layer>
Precompose) and name the comp ‘Dune Texture’. [ figure 23]

14- image map 3

Select your Psunami layer and in the ‘Image Map 3’ section,

select the ‘Dune Texture’ layer.

The ‘Map Layer’ is set to Texture On Surface. This is because

we are using the beige texture as a texture map.

Set ‘Blur Amout’ to 1.5. While noise is great for
adding some variation to the color of the sand, by
default it’s a little to sharp. Blurring it makes one
color blend nicely into the other color.

We’ll also move the map along the X axis by
setting ‘Center X’ to 40. This moves the seam

of the texture out of the view of the camera. As
mentioned earlier, if the camera was moving
around, we’d have to take much greater care about
the edges of our texture and displacement maps.
But this parameter suffices for our project.

conclusion

This project should give you something that looks
like the final image at right. [ figure 25 ]

You can also check out the ‘Main Comp’ comp for
these settings, and watch the QuickTime movie,
psu_sands-final.mov, that you downloaded. Have
fun in the sand!

= Imnage Map 3
flap Layer:
flap is:
Dizplace on:
[+ &)| Displace Intensity
[¢ & Center i (M)
[+ & Center ¥ (M)
& Angle
&) Scale ¥
&) Scale ¥
[ & Blur Arnount
Layout:

[ figure 22 ]

[ figure 23]

[ 1. dune texture =|

[ Texture On Surface

[ figure 24 ]

[ figure 25 ]
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